
 Activity 2.1 Guide 

How to Set Up a Local Root Folder and Site Structure 
The first thing to do when creating a new website with Macromedia Dreamweaver 8 is to define a site and identify a 
root folder where you will save all files, images, and other elements for the web pages. 

Setting Up a Local Root Folder 

1. Create a folder on your computer to serve as the main 
folder for your website. Give the folder a name that 
identifies the website. This folder is called the local root 
folder. 

 Note: When creating a root folder for a site on your 
computer, it is highly recommended that you place it at 
the top level of your hard drive. For example, C:\my-site 
(Windows) or Macintosh HD: my-site (Macintosh). 

2. Start Dreamweaver. 

3. From the menu bar, select Site > Manage Sites. 

 The Manage Sites dialog box opens. 

4. Click New and select Site from the pop-up menu that 
appears. 

 The Site Definition dialog box opens (Figure 1). Make 
sure the Basic tab is selected. 

5. Delete the temporary name, Unnamed Site 1. Enter a 
new name for the site and click Next. 

 Leave the URL field blank for now (or enter a URL 
given by your instructor). 

6. Make sure No, I do not want to use a server 
technology, is selected (Figure 2), and click Next. 

 

 
Figure 1 Site Definition dialog box (Basic) 

 

 
Figure 2 Site Definition dialog box, page 2 
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7. Make sure Edit local copies on my machine, then 
upload to server when ready (recommended) is 
selected (Figure 3). 

8. Click the Folder icon to the right of Where on your 
computer do you want to store your files? 

 The Choose Local Root Folder for Site dialog box opens 
(Figure 4). 

9. Locate and select the root folder you created for your 
site. Click Open and then Select (Windows), or click 
Choose (Macintosh). 

10. Click Next. 

11. Select None in the How do you connect to your remote 
server? pop-up menu (Figure 5). Click Next. 

  
Figure 3 Site Definition dialog box, page 3 

 

 
Figure 4 Choose Local Root Folder for Site 
dialog box 

 

 
Figure 5 Site Definition dialog box, page 4 
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 You are presented with a summary of your settings 
(Figure 6). 

12. Click Done. 

 Your local root folder is defined. 

13. Click Done in the Manage Sites dialog box. 

 On the right side of the Dreamweaver window, the Files 
panel displays the folders and files of your site 
(Figure 7). In Windows, the Files panel is one of the 
docked panels at the right side of the window. You can 
leave this panel open as you work. On a Macintosh, the 
left side of the Site panel shows a map of the site as you 
create it. If the panel is not docked, you may want to 
close it. 

 
Figure 6 Site Definition dialog box, page 6 

 

 
Figure 7 Files panel 

Modifying Site Information 

You can change settings for your site at any time. 

1. Select Site > Manage Sites from the menu bar. 

 The Manage Sites dialog box opens (Figure 8). 

2. Select the site name and click Edit. 

 The Site Definition dialog box opens. 

3. Change any of your original settings as desired. 

 
Figure 8 Manage Sites dialog box 
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The Dreamweaver 8 Interface 

Student Name: ________________________________________________  Date: _______________________  

The most commonly used parts of the Dreamweaver 8 interface are the Document window, the Insert bar, the 
panels, and the Property inspector. In the figure below, label the Document window, the Insert bar, the panels, and 
the Property inspector. 
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The Insert bar contains buttons for inserting various types of objects, such as images and tables, into a document 
(web page). The Insert bar contains several categories, such as Common and Layout. 

The Common category contains buttons for inserting the most commonly used objects. 

Identify the buttons on the Common Insert bar. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Identify the buttons on the Layout Insert bar. 
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The Property inspector enables you to view and change a variety of properties for the currently selected object or 
text. 

Describe the Property inspector. 
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The Dreamweaver 8 Interface 

You can access Macromedia Dreamweaver 8 tools, commands, and features by using menus or by selecting options 
from one of the Insert bars or from Dreamweaver panels. The most commonly used areas of the Dreamweaver 
interface (Figure 1) are the Document window, the Insert bar, the panels, and the Property inspector. 

The Document window displays the current document as you create and edit it. The Insert bar contains buttons for 
creating and inserting objects such as images, tables, layers, and frames you might want to add to your web pages. 
The Property inspector displays properties for the selected object or text and lets you modify those properties. The 
right side of the window, by default, displays panels you can expand or collapse as you need them. 

One of the most frequently used panels is the Files panel. This panel displays the organization of your site and lets 
you open files for editing, publish files to a server, or delete files. 

Another frequently used panel is the Assets panel. This panel provides two ways to view site assets. Site assets are 
elements used in a site, such as images, colors, or movies. 

The Assets panel provides two ways to view assets: 

• The Site list shows all of the assets in your site. 

• The Favorites list shows only the assets you’ve chosen to include in the Favorites list. 

The Document Window and Panels 

You can add and manipulate text, images, menus, tables, and other elements in the Document window, and it will 
display an approximate representation of your web page. 

 

Insert bar 

Document 
window 

Property inspector Panels 

Assets 
panel 

 

 

Figure 1 Dreamweaver 8 interface 
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The Insert Bar 

The Insert bar contains buttons for inserting various types of objects, such as images and tables, into a document. 
The Insert bar contains several categories, such as Common and Layout. The Common Insert bar (Figure 2) 
contains buttons for inserting the most commonly used objects. 

Common Insert bar 

 
Email Link Table Media Comment Tag Chooser 

 

 

Hyperlink Images Date Templates 
 

 
Named Anchor 

 

Figure 2 Common Insert bar 

Hyperlink: Insert a hypertext link. 

Email Link: Insert a link to an e-mail address. 

Named Anchor: Insert a link to a specific location on a page. 

Table: Insert a table. 

Images: Insert an image. 

Media: Insert media objects, such as Flash, Shockwave, Applets, and ActiveX. 

Date: Insert the current date, with an option for automatic updating when you save the document. 

Comment: Insert a comment, which will not be displayed on your web page. 

Templates: Make a template based on the current document. 

Tag Chooser: Insert an HTML tag. 
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Layout Insert bar 

From the Layout Insert bar (Figure 3), you can insert tables and choose among three modes. Standard mode 
displays tables as a grid of lines. Expanded Tables mode adds cell padding and spacing to tables and increases table 
borders to make editing easier, and Layout mode displays tables as boxes you can draw, drag, and resize. 

 
Insert Div Tag Layout Table Frames 

 

 
 

Table Draw Layer Draw Layout Cell Tabular Data 
 

Figure 3 Layout Insert bar 

Table: Insert a table. 

Insert Div Tag: Insert a div tag to create a content block. 

Draw Layer: Insert a layer to hold content at any location on a page. 

Layout Table: Draw a whole table with cells to hold information or objects. 

Draw Layout Cell: Draw individual cells in a table. 

Insert Row Above: Insert a row above the current row in a table. 

Insert Row Below: Insert a row below the current row. 

Insert Column to the Left: Insert a column to the left of the current column. 

Insert Column to the Right: Insert a column to the right of the current column. 

Frames: Insert a frame. 

Tabular Data: Insert tabular data, such as from a spreadsheet. 

The Property Inspector 

In the Property inspector, you can view and change a variety of properties for the currently selected object or text. 
Each kind of object has different properties. Figure 4 shows the Property inspector for a selected table. It displays 
column and row attributes, cell colors, and border colors. You can change cell padding and cell spacing as well. 
When you select text, you can alter font, size, color, and alignment in the Property inspector. 

 
Figure 4 Property inspector 
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Working with Text and Images 

Text and images are the basic elements of almost every website. You add text just as you would in a word 
processing program, and you add images by inserting them from an existing file. 

Adding Text to a Document 

Adding and modifying text works much like a word processing program. You add text by using the keyboard or by 
pasting from another document. You modify text by using the Property inspector. The Property inspector features 
icons like those found in word processing programs, such as Bold, Italic, Left Alignment, and Right Alignment. 

To add and modify text: 

1. Open a document in Macromedia Dreamweaver 8. 

2. Position the insertion point where you want to add text. 

3. Type desired text or paste text copied in another 
application. 

 Once you add text, you can change its properties in the 
text Property inspector (Figure 1). 

 Make sure the Property inspector is open. In Windows, 
it is docked at the bottom of the screen. If the Property 
inspector is not open, select Window > Properties. 

4. Select the text to be modified. 

5. In the Property inspector, change the size of the text by 
using the Size pop-up menu. 

 You can also apply a paragraph or heading format, 
apply bold or italic formatting, change text alignment, or 
change text indentation. 

 Note: You can apply different formats to separate text 
elements on a single page. 

 

 
Figure 1 Text Property inspector 
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Using Font Combinations 

In formatting text, a good practice is to assign a font combination instead of a single font. This ensures that most 
page visitors will view page text the same way. 

Font combinations determine how a browser displays text on a web page. A browser uses the first font in the 
combination that is installed in the visitor’s system. If none of the fonts in the combination is installed, the browser 
displays the text as specified by the visitor’s browser preferences. The fonts specified in Dreamweaver’s default 
font combinations are generally available on both Macintosh and Windows computers. 

Font combinations are available in the text Property inspector. 

To apply a font combination: 

1. Select the text to be formatted. 

 Make sure the Property inspector is open. In Windows, 
it is docked at the bottom of the screen. If the Property 
inspector is not open, select Window > Properties. 

2. In the Property inspector, apply a font combination, 
using the Font pop-up menu (Figure 2). 

 Note: You can apply different font combinations to 
separate text elements on a single page. 

 

Figure 2 Text Property inspector with font 
selected 
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Adding Images 

You can insert any image into a web page, as long as it is accessible to Dreamweaver and in a web format. Most 
images in web pages are either GIFs or JPEGs. 

To add an image: 

1.  Open a document in Macromedia Dreamweaver 8. 

2. Make sure the document is saved in your site’s local 
folder. 

3. Position the insertion point where you want to add an 
image. 

4. Select Insert > Image. 

 The Select Image Source dialog box opens (Figure 3). 

5. Browse to the folder with the desired image. 

6. Select the desired image. 

 A preview of the image appears in the right side of the 
dialog box. 

7. Click OK. 

 If the image is not in your site folder, Dreamweaver 
asks if you want to copy the file there (Figure 4). 

8. Click Yes. 

9. Browse to the folder where you want to copy the file. 

 The Image Tag Accessibility Attributes dialog box 
opens (Figure 5). This dialog box lets you add a 
description to the image so that screen readers can 
interpret it. 

10. Enter a brief description. You can also provide a link to 
a file with a longer description. 

11. Click OK. 

 The image is added to your document. 

 

Figure 3 Select image source dialog box 

 

 
Figure 4 File outside of root folder warning 
message 

 

Figure 5 Image Tag Accessibility Attributes 
dialog box 
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Resizing Images 

You can resize an image by clicking on it and dragging selection handles. 

Note: Changing the width or height of your image in Dreamweaver can reduce the image quality. It is better 
practice to resize an image in an image-edited program such as Macromedia Fireworks 8 before importing it into 
Dreamweaver.  

To resize an image in Dreamweaver: 

1. Select the image. 

 Selection handles appear on the right and bottom edges 
of the image (Figure 6). 

2. Do one of the following. 

• To resize the image horizontally, drag the selection 
handle in the right. 

• To resize the image vertically, drag the selection 
handle in the bottom. 

• To resize in both directions at the same time, drag 
the selection handle at the lower right corner. To 
retain the relative proportion of height and width, 
hold down Shift as you drag. 

 

 
Figure 6 Image with selection handles 
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How to Create a Basic Table 

In Macromedia Dreamweaver 8, you can add text and images to table cells the same way you add text and images to 
a page. After you create a table, you can easily modify both its appearance and its structure. 

Inserting a Table on a Page 

You can insert a table anywhere on a page, including within another table. You can quickly insert a standard table 
with three rows and three columns, or you can modify options to insert a custom table. 

When you insert a table, a good idea is to set a header property for a row or column if you will use that row or 
column to provide labels for the information in the table. A header makes the table more accessible to people with 
visual impairments, because screen readers can recognize that a header contains labels. (Note that you must set a 
header row or column to provide such accessibility. It is not sufficient to use bold or centered text.) 

To insert a table: 

1. Open a document in Macromedia Dreamweaver 8. 

2. Place the insertion point in your document where you 
want the table to appear. 

3. Select the Layout category on the Insert bar. 

 Make sure the Standard mode button is selected 
(Figure 1). 

4. Click the Insert Table button on the Layout Insert bar. 

 The Table dialog box opens (Figure 2). 

5. Enter the number of rows and columns. 

6. Make changes to any of the options in the dialog box. 
For information about the options, click the Help button 
in the dialog box. 

 Applying a column header or row header in particular 
can improve the accessibility of a data table. Though not 
visible on the page, such headers are read by screen 
readers. 

To set a header row or column: 

7. Select one of the options in the Header section. 

 For example, if you create a table that lists a collection 
of books, with columns labeled Author, Title, and Year, 
you should set the top row as a header. By default, 
header rows or columns are bolded and centered 
(Figure 3). Screen readers can now read this header. 

8. Click OK. 

 The table appears in your document. 

 

 

Figure 1 Layout Insert bar with Standard mode 
selected 

 

Figure 2 Table dialog box 

 

 
Figure 3 Table with top row set as header 
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Selecting Table Elements 

You can select an entire table, a row, or a column, or you can select a contiguous block of cells within a table. After 
you’ve selected a table or cells, you can modify the appearance of the selection or of the text contained in the 
selection. 

To select an entire table: 

Do one of the following: 

• Click the upper left corner of the table or click 
anywhere on the right or bottom edge. 

• Click in a table cell, and then select 
Modify > Table > Select Table. 

 Selection handles appear on the selected table’s lower 
and right edges (Figure 4). 

To select rows or columns: 

1. Position the pointer to point at the left edge of a row or 
the top edge of a column. 

2. When the pointer changes to a selection arrow, click to 
select the row or column, or drag to select multiple rows 
or columns (Figure 5). 

To select a single cell: 

Do one of the following: 

• Click in the cell. Then drag to select the cell. 

• Click in the cell. Then select Edit > Select All. 

 

 
Figure 4 Selection handles on a selected table 

 

 
Figure 5 A selected column in a table 
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Adding Rows and Columns 

You can add a single row or column, or you can add multiple rows or columns at the same time. 

To add a row: 

1. Place the insertion point in a table cell, or select an 
entire row. 

2. Do one of the following: 

• Click the Insert Row Above or the Insert Row 
Below button (Figure 6). 

• Select Insert > Table Objects > 
Insert Row Above or Insert > 
Table Objects > Insert Row Below. 

 A new row appears below the insertion point or the 
selected row. 

To add a column: 

1. Place the insertion point in a table cell, or select an 
entire column. 

2. Do one of the following: 

• Click the Insert Column to the Left or the Insert 
Column to the Right button (Figure 5). 

• Select Insert > Table Objects > Insert Column to 
the Left or Insert > Table Objects > Insert 
Column to the Right.  

 

 

Figure 6 Layout Insert bar 

 

Insert C
buttons

olumn Insert 
Row 

Deleting Rows and Columns 

You can delete a single row or column, or you can delete multiple rows or columns at the same time. 

To delete rows or columns from a table: 

1. Select one or more rows or columns. 

2. Press Delete or Backspace. 

To remove cell contents, but leave the cells intact: 

1. Select one or more cells. 

2. Select Edit > Clear or press Delete. 

 Note: If you select an entire row or column, and then 
select Edit > Clear or press Delete, Dreamweaver 
removes the entire row or column—not just their 
contents—from the table. 
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Resizing Tables, Rows, and Columns 

You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the 
table resize proportionately. 

To resize a table: 

Select the table and do one of the following. 

• To resize the table horizontally, drag the selection 
handle in the right. 

• To resize the table vertically, drag the selection 
handle in the bottom. 

• To resize in both dimensions, drag the selection 
handle at the lower right corner. 

To resize a column’s width: 

Select the column and do one of the following: 

• Drag the right border of the column. 

• In the Property inspector (Figure 7), change the 
number in the Column Width text box. 

To resize a row’s height: 

Select the row and do one of the following: 

• Drag the lower border of the row. 

• In the Property inspector (Figure 7), change the 
number in the Row Height text box. 

 

Figure 7 Table Property inspector 
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Modifying Table Properties 

You can modify the properties of a table, its rows and columns, or its cells by using the Property inspector. 
Attention to table borders and cell padding in particular can help you create effective table designs. 

You can also set a row or column as a header by using the Property inspector. Headers help make tables more 
accessible. 

To modify table properties: 

1. Select the table you want to modify. 

 Make sure the Property inspector is open (Figure 8). In 
Windows, it is docked at the bottom of the screen. If the 
Property inspector is not open, select 
Window > Properties. 

2. Make changes to any of the options in the Property 
inspector (Figure 8). 

To modify table row or column properties: 

1. Select the row or column you want to modify. 

2. Make changes to any of the options in the Property 
inspector. 

To modify table cell properties: 

1. In your document, select the cell or cells you want to 
modify. 

2. Make changes to any of the options in the Property 
inspector. 

To set a row or a column as header: 

1. Select a row or column. 

2. In the Property inspector, check Header. 

 The words in the row or column will appear centered 
and bolded (Figure 9). 

 

Figure 8 Table Property inspector 

 

 
Figure 9 Table with top row set as header 
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The Dreamweaver 8 Insert Bar 

Student Name: ________________________________________________  Date: _______________________  

The Insert bar contains buttons for inserting various types of objects, such as images and tables, into a document 
(web page). The Insert bar contains several categories, such as Common and Layout. 

Identify the buttons on the Common Insert bar. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

Identify the buttons on the Layout Insert bar. 
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Describe the contents of the other categories of the Insert bar. 

Forms category: _______________________________________________________________________________  

____________________________________________________________________________________________  

Text category: ________________________________________________________________________________  

____________________________________________________________________________________________  

HTML category: ______________________________________________________________________________  

____________________________________________________________________________________________  

Application category:___________________________________________________________________________  

____________________________________________________________________________________________  

Text category: ________________________________________________________________________________  

____________________________________________________________________________________________  

Flash elements category: ________________________________________________________________________  

____________________________________________________________________________________________  

Favorites category:_____________________________________________________________________________  

____________________________________________________________________________________________  

 

On the Insert bar below, indicate where you can switch back and forth between categories: 

 

 

 

How do you switch between “Show as Menu” and “Show as Tabs”? _____________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

2 - 88   The Dreamweaver 8 Insert Bar 



 Activity 2.1 Guide 

The Dreamweaver 8 Insert Bar 

The Insert bar contains buttons for inserting various types of objects, such as images and tables, into a web page. 

You can use the Insert bar to create or insert content in eight categories: 

• The Common category contains buttons for inserting the most commonly used objects, such as links, images, 
and tables. 

• The Layout category gives you options to insert tables, div tags, layers, and frames. You can choose among 
three views of tables: Standard (default), Expanded Tables, and Layout. When you select Layout mode, you 
can use the Dreamweaver layout tools: Draw Layout Cell and Draw Layout Table. 

• The Forms category contains buttons for creating forms and inserting form elements. 

• The Text category is used for working in Code view and enables you to insert a variety of text- and list-
formatting tags, such as b, em, p, h1, and ul. 

• The HTML category is used for working in Code view and enables you to insert HTML tags for horizontal 
rules, head content, tables, frames, and scripts. 

• The Application category lets you insert dynamic elements such as recordsets, repeated regions, and record 
insertion and update forms. 

• The Flash elements category lets you insert Macromedia Flash elements. 

• Use the Favorites category to customize a list of Insert bar buttons for fast access. You can customize this 
category by right-clicking (Windows) or Control-clicking (Macintosh) the Insert bar. 

The Insert Bar Menu 

You switch between these categories by using the Insert bar menu, which is located on the left side of the Insert bar 
(Figure 1). 

 
Figure 1 Insert bar menu 

You can also view the Insert bar categories as tabs (Figure 2). 

On the Insert bar menu, select Show as Tabs to switch to tabs view. 

 
Figure 2 Insert bar in tabs view 

To return to menu view, select Show as Menu from the context menu on the right side of the Insert bar. 

 The Dreamweaver 8 Insert Bar   2 - 89 





 Activity 2.2 Worksheet 

Analyzing Websites 

Name:_______________________________________________________  Date: _______________________  

URL: _______________________________________________________  

Site Name: ___________________________________________________  

Category: ____________________________________________________  

Visual Layout 

Describe the visual elements on the home page. What caught your eye first? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

How does the graphic design (balance, emphasis, color, tone, and so on) communicate the content? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

If there are images on the page, do they add value to the content, or are they for decoration and appeal? If they add 
value, describe how. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

 Analyzing Websites   2 - 91 



Activity 2.2 Worksheet  

How quickly did the page draw? Was it worth the wait? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

How well does the layout of text help viewers understand the main points of the site content? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Consistency Structures 

Are any of the elements repeated on subsequent pages? Are the elements decorative or part of the navigation? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Does the repetition help or hinder the overall purpose of the website? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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How consistent is the placement of the navigation scheme? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

How consistent is the use of color? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

How consistent are fonts and font sizes? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Color Scheme 

Does the color scheme add to the purpose or tone of the site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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How does the color scheme help or hinder in conveying the purpose of the site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Content Bias 

Can you tell why the site was created? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Can you distinguish facts from opinions? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Is there any bias in the information presented? Is there a hidden purpose? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Content Currency 

When was the information first placed on the page? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

When was it last revised? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Are there any other indications that this information is current? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

Content Source 

Who is responsible for this site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

What qualifications or expertise does the author have to write about the topic on this site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Is there a way to verify the legitimacy of the author, such as an e-mail address, phone number, or mailing address? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Who sponsors this site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Are any other sources cited on this site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

What is the domain extension of the site? What does this extension tell you about the site? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Content Corroboration 

What other sites have information on this topic? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Is the information the same? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Are these other sources valid? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 Analyzing Websites   2 - 97 





 Activity 2.3 Guide 

Digital Design File List 

You may have some or all of these documents: 

• Text document with images from the web (Unit 1) 

• Web search images (Unit 1) 

• Scanned images (originals) 

• Text document that contains annotated notes for the scanned images (Unit 1) 

• Digital camera photographs (Unit 1) 

• Text document that contains annotated notes and photographs (Unit 1) 

• Optimized GIF and JPEG images (Unit 1) 

• Nameplate (Unit 1) 

• Nameplate interview (Unit 1) 

• Logo storyboard (Unit 1) 

• Logo (Unit 1) 

• Logo redesign (Unit 1) 

• Page banner storyboard (Unit 1) 

• Page banner (Unit 1) 

• Page banner redesign (Unit 1) 

• Technical test plan document (Unit 2) 

• Technical test outcome document (Unit 2) 

• Usability test plan document (Unit 2) 

• Usability test outcome document (Unit 2) 

Other files your class created:
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Student Portfolios 

The content and purpose of a portfolio can vary widely. Student portfolios typically contain examples of work as 
well as text descriptions and reflections on each piece. Three types of electronic portfolios showcase work, 
document progress through a project, or highlight skill growth. Examples of these three types follow. 

Showcase Portfolio 

A showcase portfolio highlights its owner’s expertise by showing examples of best work. A student showcase 
would include a selection of finished images, designs, and websites. It might also provide a reflection in the piece or 
document of the process students followed to create it. Following is a sample category outline with associated files: 

Image work 

• Digital camera photographs 

• Optimized images 

Design work 

• Logo 

• Page banner 

Client website 

(To be completed later) 
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This is a sample flowchart for a showcase portfolio: 

 

Client Site  
(to be 

completed 
later) 

 
Design 
Work 

 
Image Work 

 
Logo 

 
Page 

Banner 

 
Optimized 

Images 

 
Home Page  
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Skill Growth Portfolio 

A skill growth portfolio shows multiple samples of work in the same project to demonstrate increasing skill. For 
example, students include several versions of their page banners to show how the design evolved. This portfolio can 
also include reflection and discussion of redesigns. Following is a sample category outline with associated files: 

Design Work 

Logo 

• Logo (early version) 

• Logo (final version) 

• Logo self-review 

Page banner 

• Page banner (early version) 

• Page banner (final version) 

• Page banner peer review 

Interactive graphic (to be completed later) 

Client site (To be completed later) 

• Client site (early versions) 

• Client site (final version) 

• Client site reflections 
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This is a sample flowchart for a skill growth portfolio: 

 

Client Site 
(to be 

completed 
later) 

 
Early 

Version 

 
Final 

Version 

 
Early  
Logo 
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Self-Review

 
Final  
Logo 
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Early  
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Banner 

Final  
Page  

Banner 

Page 
Banner 

Peer 
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Home Page 
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Project Progress Portfolio 

A project progress portfolio contains a more complete selection of work around a particular project. The portfolio 
reflects the span of work done on a project—showing stages from early ideas to completion. An example would be 
to show all the work students did while learning Macromedia Fireworks. The portfolio would include sketches and 
storyboards, early versions, final versions, peer review, and self-review. For this portfolio type, students will need 
to scan worksheets and other handwritten documents to create electronic versions.
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How to Plan a Portfolio 

Planning a website by using information architecture is a common practice for professional designers. Designers 
create a flowchart that shows all the pages in the site and how they connect. The flowchart can also describe the 
purpose and audience for a site and provide organized lists of content. 

Create a flowchart for your portfolio that shows the organization and content of your work in this course. Include 
the following: 

1. Describe the purpose of the portfolio. 

2. Include a list of assets in the portfolio, and organize files and projects into categories. 

3. Using the category outline as a guide, draw a flowchart for your electronic portfolio. 
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Naming Conventions 

How you name your files is important. Good file and folder names make developing your site easier (especially 
when you work with other people). They also help site visitors find your files. If you’re working with other people, 
it’s a good idea to discuss how you will name your files. 

The following tips apply to all files used on the web—HTML files, image files, Flash movies, and so on. 

 
Tip Reason Example 

Give files unique, meaningful 
names. 

Because you cannot put two files with the 
same name in one folder, all filenames need to 
be different. Use filenames that indicate the 
contents of the files. 

feedback_button.gif 
instead of button3.gif 

class-pet.jpg instead of 
roo-roo.jpg 

Use meaningful folder names. Folders help you organize content. If their 
names are not meaningful, they will be less 
helpful. 

images  
instead of  
folder_2 

Use lowercase letters instead of 
uppercase (capital) letters. 

Using a mix of uppercase and lowercase 
letters increases the possibility of broken 
links, because some web servers differentiate 
between upper and lowercase. 

class_home.htm  
instead of  
Class_Picture.htm 

Use file extensions (.htm, .gif, 
.jpg) consistently. Although you 
can use either .htm or .html, you 
should be consistent about using 
one or the other. 

Using a mix of file extensions also increases 
the possibility of broken links. 

index.htm and 
directions.htm 
instead of 
index.html and 
directions.htm 

If you’re working on a Macintosh, 
make sure you always include a 
file extension. 

Although Windows requires file extensions, 
Macintosh does not. Web browsers need file 
extensions in order to display files. 

index.htm instead of index 

Use a hyphen (-) or an underscore 
(_) instead of a space. 

Some web browsers do not recognize spaces. my-dog.gif or my_dog.gif 
instead of  
my dog.gif 

Use letters and numbers. Many special symbols aren’t recognized by 
web browsers. 

my2friends.gif instead of 
me&friends.gif 

Keep filenames as short as 
possible. 

Not only does this help prevent broken links, 
but some web servers will cut off names at 25 
characters. 

park_directions.htm 
instead of  
directions_to_the_fourth_
street_park_plus_a_map.
htm 
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File Management Folders 

Name: ______________________________________________________  Date: _______________________  
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File Management 

Name: ______________________________________________________  Date: _______________________  

Part I. As you create a file management strategy, describe the method you use by answering the following 
questions: 

Questions File Management Notes 

How are you categorizing the files? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 
How does your file organization help you find particular 
files? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

 
 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

How easy to understand are your file and folder names? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 File Management   2 - 113 



Activity 2.4 Worksheet  

Part II. Write the name of the file you are searching for, its content, and the location in which you found it. Then 
answer the questions that follow. 

Example: 

Filename: carrot.gif 

File content: science 

File location: john_doe/science/images/carrot.gif 

 

Filename: __________________________________  

File content: _________________________________  

File location: ________________________________  

 

Filename: __________________________________  

File content: _________________________________  

File location: ________________________________  

 
Was it difficult to find this file? Why or why not? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

Was it difficult to find this file? Why or why not? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

Was the file located in a folder you expected? If not, 
where did you expect the file to be located? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

Was the file located in a folder you expected? If not, 
where did you expect the file to be located? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

 

Did the names of the folders and files make sense to 
you? Why or why not? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  

Did the names of the folders and files make sense to 
you? Why or why not? 

___________________________________________  

___________________________________________  

___________________________________________  

___________________________________________  
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Planning a Home Page 

The home page storyboard includes a design layout (graphics, text, and site navigation scheme) to make creating the 
home page easier. Use the following guidelines to help you create the storyboard of your home page on paper. 

Graphics 

Draw rectangles on the page to indicate the size and placement of graphics. Label these rectangles with the 
filenames of the graphics they represent. 

• What graphics will you include on the home page? 

• Where will you place the graphics on the page? 

Text 

Draw rectangles on the page to indicate the text placement. Label these rectangles with content descriptions. 

• What text will you include on the home page? 

• Where will you place text on the page? 

Navigation 

Draw a rectangle to indicate the placement of the links to other pages. Label this rectangle with the names of the 
other pages. (You will build graphical buttons for these links later in this course.) 

• According to your flowchart, the home page directly links to what pages (what are the menu items)? 

• Where will you place these links on your home page? 

Color 

Indicate the background and text colors on your storyboard.
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How to Lay Out a Web Page with Layers 

You can use Dreamweaver’s table design features to create a simple page layout. However, a more powerful 
technique is to use layers, which are based on Cascading Style Sheets (CSS). A layer is a rectangular HTML 
element that you can position anywhere on a page. Layers can contain text, images, or any other content you can 
ordinarily place in the body of an HTML document. 

Many designers prefer CSS-based layouts because CSS gives greater control over the positioning of elements, 
reduces the amount of code you need, and enables you to format layout blocks with margins, borders, and colors. In 
addition, people using screen readers to view web pages have a much easier time browsing pages built with CSS 
because the code is simpler and shorter. 

Create a New Page 

1. Start Macromedia Dreamweaver 8. 

2. Make sure the Files panel is visible (Figure 1). In 
Windows, it is docked at the right side of the screen. If 
the Files panel is not open, select Window > Files. 

3. Make sure your portfolio site is selected. If it is not, 
click the site pop-up menu and select your portfolio site.

4. Select File > New. 

 The New Document dialog box opens (Figure 2). 

5. Under Basic page, click HTML. 

6. Click Create. 

 A new untitled HTML document opens. 

7. To save the untitled document as your home page, select 
File > Save As. 

 The Save As dialog box opens to the root folder of your 
portfolio site automatically. 

8. Name the new page index.html and click Save. 

 
Figure 1 Files panel 

 

 
Figure 2 The New Document dialog box 

 

Site menu 
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 The new file, index.html, is added to the root folder in 
the Files panel (Figure 3). 

 

 
Figure 3 Files panel showing index.html 

Insert a Layer 

1. Select the Layout category on the Insert bar. 

 Make sure the Standard mode button is selected 
(Figure 4). 

2. Click the Draw Layer button (Figure 4). 

 The mouse pointer changes to a cross when you move it 
over the page. 

3. Select one of the page areas on your storyboard. Drag a 
layer in the Dreamweaver document that matches the 
page area’s size on your storyboard, and release the 
mouse button.  

 Make sure not to click on the page again. You want to 
leave the new layer selected (Figure 5). 

4. Make sure the Property inspector is open (Figure 1). In 
Windows, it is docked at the bottom of the screen. If the 
Property inspector is not open, select 
Window > Properties. 

5. In the Layer ID box, enter a name for the layer.  

 Choose a name that will help you remember the layer’s 
contents, such as header or navigation. 

6. Click the Bg color box and select a color in the color 
picker.  

 The layer changes to the selected color. 

7. Open the Layers panel (Window > Layers).  

 You’ll see that Dreamweaver has added the new layer to 
the list of layers.  

8. Click once outside the new layer to deselect it.  

 A thin black line appears around the layer. This line 
does not appear in a browser. If you do not see the line, 
select View > Visual Aids > Layer Outlines. 

9. Continue adding layers for all the sections on your 
storyboard. You can locate layers directly alongside one 
another (Figure 7). 

 

Figure 4 Insert bar, Layout category 

 

Figure 5 Layer inserted and selected 

 

Figure 6 Layer Property inspector 

 

 

Figure 7 Multiple layers on page 

Draw Layer button

Layers panel
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10. Save your page. 

Resize Layers 

You can resize an individual layer or simultaneously resize multiple layers to make them the same width and height. 

Note: If the Prevent Overlaps option is checked in the Layers panel, you will not be able to resize a layer so it 
overlaps with another layer. 

1. Select a layer by clicking on its border or by clicking the 
layer’s name in the Layers panel. 

2. Do one of the following to resize the layer: 

• To resize by dragging, drag any of the layer’s resize 
handles (Figure 7). 

• To resize one pixel at a time, hold down Control 
(Windows) or Option (Macintosh) while pressing 
an arrow key. 

 Note: The arrow keys move the right and bottom 
borders of the layer; you can’t resize the top and left 
borders with this technique. 

• In the Property inspector, type values for width 
(W) and height (H).  

 
 
Figure 8 Resize by dragging 

Layer resize handle 

Move Layers 
You can move layers in Design view in much the same way you move objects in most basic graphics applications. 

To move one or more selected layers: 

1. Select one or more layers. 

2. Do one of the following: 

• To move by dragging, drag the layer’s selection 
handle. 

• To move one pixel at a time, use the arrow keys. 

 Note: If the Prevent Overlaps option is checked in the 
Layers panel, you will not be able to move a layer so 
that it overlaps another layer.  

 
Figure 9 Moving a layer 

Selection 
handle 
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Add Content to Layers 

You can images, text, and other content (such as Flash movies) to your layers just as you would elsewhere in a web 
page. 

1. To insert an image in a layer, click in the layer and 
select Insert > Image on the menu bar. 

 Note: Make sure the layer is sized large enough to hold 
the image or other content. If the layer is sized smaller 
than the image, the layer may not display correctly in all 
browsers. 

2. In the Select Image Source dialog box, locate and select 
an image to insert (such as your page banner). Then 
click OK (Windows) or Choose (Macintosh). 

 The image appears on the layer (Figure 10). 

3. To format the image on the layer, select the image and 
select formatting elements in the Property inspector. 

4. To add text to a layer, click in the layer and type text or 
paste text copied from another document. 

5. To format text, select the text and select formatting 
elements in the Property inspector, such as font, 
alignment, and size of the text. 

Figure  10 Layer with image added 

Preview a Page 

 To preview the page in a browser (Figure 12), select 
File > Preview in Browser and then select a browser 
from the submenu (or press F12). 

 Note: It is important to preview in a browser to make 
sure your design fits in a standard browser window. Try 
resizing the browser window to see the effect on your 
page. 

Figure 12 Web page in browser 
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Creating Consistent Content Pages 

Content pages link from the electronic portfolio’s home page. Using the ideas from the class discussion, determine 
the consistent elements of your content pages and plan your navigation bar. Create a checklist of items that will 
appear on each page by answering the following questions. Then draw a general layout of a content page, drawing 
and labeling the elements that will appear on all content pages. 

Organizing Content 

How you organize content on a page highlights important features and elements of your site. Important elements 
might be higher in the page, larger in size, or in stronger colors. Include rough descriptions of navigation, copy 
layout, graphic allocation, key headers, and other elements that appear on a screen. Identifying common structures 
between pages helps visitors understand they are in the same site as they navigate from page to page. 

• Will your page banner be on each page? If yes, is it in the same place? Is it the same size? 

• What font will you use for titles or headings on your content pages? 

• What color will you use for titles or headings on your content pages? 

• What font will you use for descriptions on your content pages? 

• What color will you use for descriptions? 

Navigation 

For visitors of your website to understand the content, you must provide clear navigation. Visitors need to know 
where they are in a site, where they need to go, and how to get back to where they came from. Having a consistent 
layout grid helps orient visitors and keeps them from feeling lost. Using consistent buttons, links, and graphics on 
each page maintains a sense of place. As visitors move from page to page, provide familiar visual cues and 
navigational aids. 

Here are some questions to answer: 

• Where will you place the navigation bar on the page? 

• What content will be on the navigation bar? 

• Will the navigation bar be on every page? 

• How will your navigation bar help visitors know which page they are on? 
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How to Set Document Properties 

You can use the Page Properties dialog box to set page layout and formatting properties, such as a default font 
family, font size, font color, and background color. 

Set Document Properties 

1. Open a document in Dreamweaver 8. 

2. Select Modify > Page Properties. 

 The Page Properties dialog box opens (Figure 1). 

Change the default font for a page 

1. Select a font in the Page font pop-up menu. 

2. Select a font size in the Size pop-up menu. 

 Any unformatted text will appear in the selected font 
and font size. 

Change the default text color for a page 

1. Click the Text color box. 

2. Select a color in the color picker (Figure 2). 

Change the background color of a page 

1. Click the Background color box. 

2. Select a color in the color picker (Figure 3). 

For information about other options in the Page 
Properties dialog box, click Help. 

3. Click OK to close the Page Properties dialog box. 

 

Figure 1 Page Properties dialog box 

 

Figure 2 Text color picker 

 

Figure 3 Background color picker 

 

.
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How to Create Lists 

You can create numbered lists and bulleted lists from existing text or from new text as you type in the Document 
window. Numbered lists are also called ordered lists. Bulleted lists are also called unordered lists. 

Creating Numbered Lists 

You can use numbered lists (Figure 1) to organize information that needs to be in order. You can apply numbering 
as you create the list, or you can add numbering to an existing list. 

To create a numbered list: 

1. Place the insertion point in your document where you 
want to add the list, and then click the Ordered List 
button in the Property inspector (Figure 2). 

2. Type the first list item. 

3. Press Enter (Windows) or Return (Macintosh) at the 
end of each list item to type another item. 

4. When you finish typing the list, press Enter (Windows) 
or Return (Macintosh) twice to turn off the list 
function. 

To create a numbered list from existing text: 

1. Select multiple lines of existing text. 

2. Click the Ordered List button in the Property inspector 
(Figure 2). 

 

Figure 1 A numbered list 

 

 

Figure 2 List buttons in the Property inspector 
Unordered list Ordered list 

Creating Bulleted Lists 

Use bulleted lists (Figure 3) to organize information that does not need to be in order. You can apply bullets as you 
create the list, or you can add bullets to an existing list. 

To create a bulleted list: 

1. Place the insertion point in your document where you 
want to add the list, and then click the Unordered List 
button in the Property inspector (Figure 2). 

2. Type the first list item. 

3. Press Enter (Windows) or Return (Macintosh) at the 
end of each list item to type another item. 

4. When you finish typing the list, press Enter (Windows) 
or Return (Macintosh) twice to turn off the list 
function. 

To create a bulleted list from existing text: 

1. Select multiple lines of existing text. 

2. Click the Unordered List button in the Property 
inspector (Figure 2). 

 

Figure 3 A bulleted list 
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How to Add Text from Another Document 

Copy Text from Another Document 

1. Open the document from which you want to copy text. 

2. Select the text and select Edit > Copy. 

3. Start Dreamweaver 8. 

4. Open the Dreamweaver document in which you want to 
paste the text. 

5. Position the insertion point in the page where you want 
to paste the copied text. 

6. Select Edit > Paste. 

 The new text appears in the Dreamweaver document. 

 Note: Copied text may lose some of its original 
formatting, including line breaks and paragraph breaks. 
To insert a blank line after a section of text, position the 
insertion point at the end of the last text line and press 
Enter (Windows) or Return (Macintosh). To create a 
line break at the insertion point, press Shift-Enter 
(Windows) or Shift-Return (Macintosh). 

7. To change the format of any new text in the document, 
select the text and set options in the Property inspector. 

 

 

Import Word HTML 

HTML pages created in Microsoft Word have elements that need to be cleaned up before you can work with these 
pages in Dreamweaver. 

1. Select File > Open. 

 The Open dialog box opens. 

2. Navigate to and select the HTML file you want to open, 
and click Open. 

 The Word HTML file is opened in Dreamweaver. 

3. Select Commands > Clean Up Word HTML. 

 The Clean Up Word HTML dialog box opens 
(Figure 1). 

4. Click OK. 

 You are presented with a summary of the cleanup 
process. 

5. Click OK. 

 Use the Property inspector to edit the text as necessary. Figure 1 Clean Up Word HTML dialog box 
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How to Import Spreadsheet Tables 
You can import a spreadsheet table created in a program such as Microsoft Excel into your Macromedia 
Dreamweaver 8 page. Save the spreadsheet file in tab-delimited (txt) or comma-separated-values format (csv). 
These tables are a quick way for setting up the layout for a catalog or directory of information. 

Save the Spreadsheet in TXT or CSV Format 

1. Open the spreadsheet file in the program in which you 
created it, such as Microsoft Excel. 

2. Select File > Save As. 

3. For the file format, select either Text (Tab delimited) 
or CSV (Comma delimited) from the Save as type 
(Windows) or Format (Macintosh) pop-up menu to save 
the spreadsheet as a data file. 

4. Save and close the spreadsheet program. 

 

 

Insert the Spreadsheet into a Dreamweaver Document 

1. Start Dreamweaver and open the document into which 
you want to insert the spreadsheet table. 

2. Select the Layout category on the Insert bar and click 
the Tabular Data button (Figure 1). 

 The Import Tabular Data dialog box opens (Figure 2). 

3. In the dialog box, click Browse and select the 
spreadsheet file. Click Open. 

4. On the Delimiter pop-up menu (Figure 3), select Tab if 
you saved the spreadsheet file in tab-delimited format or 
select Comma if you saved the file in CSV format. 

5. Click OK to close the Insert Tabular Data dialog box. 

 

 
Figure 1 Tabular Data button on Insert bar 

 

 
Figure 2 Import Tabular Data dialog box 

 

 
Figure 3 Delimiter pop-up menu 
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Format a Data Table 

1. To format the imported table, select the table in the 
Dreamweaver document (Figure 4) and use the 
Property inspector to set formatting options, or select 
either Format Table or Sort Table from the 
Commands menu. 

 

 

Figure 4 Table selected 
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How to Create Links 

There are several different types of links in Macromedia Dreamweaver 8: 

• Internal link (document-relative pathname link or site-root-relative pathname link) goes to another page in 
your site. 

• External link (absolute pathname link) goes to another site. 

• Named Anchor link goes to a specific position on a page in your site. 

• E-mail link opens a blank e-mail message window instead of linking to a page. 

Creating an Internal Link  

1. Select an image, a word, or a phrase of text you want to 
format as a link. 

 Make sure the Property inspector is open (Figure 1). In 
Windows, it is docked at the bottom of the screen. If the 
Property inspector is not open, select 
Window > Properties. 

2. Beside the Link text box in the Property inspector 
(Figure 1), click the Browse for File (file folder) icon. 

 The Select File dialog box opens (Figure 2). 

 Note: If you have the Files panel open, you can also 
click the Point to File icon beside the Link text box and 
then click and drag to draw a link line to the target file 
in the Files panel. The name of the file you point to will 
be added to the Link text box automatically. 

3. Browse to the file you want to link and click on it. 

4. Click OK. 

 The Select File dialog box closes. The filename appears 
in the Property inspector. 

 

 
 

Figure 1 Text Property inspector 

 

 
Figure 2 Select File dialog box 

Point to 
File 

Browse for 
File 

Creating an External Link 

1. Select an image or text you want to format as a link. 

2. In the Link text box in the Property inspector, type or 
paste the address (URL) of the site to which you want to 
link (Figure 3). 

 Remember to include “http://” in the address. 

 
Figure 3 URL in Link text box 
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Creating a Link to a Named Anchor 

To link to a specific location on a web page, first create a named anchor at that location, and then link to the named 
anchor.  

1. Position the insertion point at the location on the page 
where you want to define an anchor. 

2. Select Insert > Named Anchor. 

 The Named Anchor dialog box opens (Figure 4). 

3. Enter a short anchor name without any spaces. 

4. Click OK. 

5. Select an image or text to link to the named anchor. 

6. In the Link text box in the Property inspector, type “#” 
and then type or paste the anchor name. 

 
Figure 4 Named Anchor dialog box 

Creating a Link to an E-mail Address 

You can add a link to an e-mail address. When visitors click the link, their default mail applications will launch. 

1. Click in the document where you want the link to 
appear, or select the text or image you want to format as 
the e-mail link. 

2. Do one of the following to insert the link: 

• Select Insert > Email Link. 

• In the Common category of the Insert bar, click the 
Insert Email Link button. 

 The Email Link dialog box opens (Figure 5). 

3. In the Text box, enter text for the link. 

 If you selected text to format as the link, that text 
appears in the Text box. 

4. In the E-Mail text box, type the e-mail address. 

5. Click OK to close the Email Link dialog box. 

Figure 5 Email link dialog box 
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Usability 

Student Name: ________________________________________________  Date: _______________________  

URL: _______________________________________________________________________________________  

Site Name: ___________________________________________________________________________________  

 

What types of navigation elements are used: buttons, hyperlinks, images, something else? One type or several? 
Describe each type of navigation element. 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

As you navigate, how many clicks does it generally take to get to information you are seeking? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

As you navigate, do you get to the information you are expecting? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Is the site structure apparent? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

How long does it take for pages to load? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Is the text readable? Is the text uniquely styled? If so, does the styling add value to the purpose? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

What are the elements of the visual layout? How do these elements make it easier or more difficult for visitors? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Are there clear titles, headings, or other visual elements that specifically help organize the information? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Accessibility 

Student Name: ________________________________________________  Date: _______________________  

URL: _______________________________________________________________________________________  

Site Name: ___________________________________________________________________________________  

 

Do the images have alternative text (Alt tags) so screen readers can read the description? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Are all the links, including embedded links, labeled so they can stand alone? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Do data tables have header rows or header columns? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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Are there clear titles and headings that help organize the information for someone using a screen reader? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Is the navigation scheme positioned conveniently for someone using a screen reader? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

 

Is color the only element used to convey emphasis? 

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  

____________________________________________________________________________________________  
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How to Create Buttons and Navigation Bars 

Macromedia Fireworks 8 enables you to design the look and functionality of buttons, including links and rollover 
features. After you export these buttons from Fireworks, you can import them into Macromedia Dreamweaver 8. 

Build a Button 

1. Start Fireworks. Create a new document. Type 200 pixels for Width and 200 pixels for Height. Type 72 
pixels/inch for Resolution. 

 Note: At the end of this exercise, you will trim the canvas to fit the button. 96 dpi is the highest resolution that 
most monitors can display. 

2. Save the document in the images folder of your Dreamweaver website. 

3. Select Edit > Insert > New Button. 

 The Button Editor opens (Figure 1). 

 Buttons contain four states: 

• • Up (button untouched) 

• • Over (pointer over button) 

• • Down (button being clicked) 

• • Over While Down (pointer over while button held down) 

 
Figure 1 Button Editor with Up state 

4. Use the Rectangle tool or the Ellipse tool from the Tools panel to draw a shape for the Up state. Make the 
dimensions of the shape fit the size of your navigation bar. 

5. To add depth to the button, click the Add Live Filters button in the Property inspector (the plus sign next to 
Filters), and then select a bevel option from the pop-up menu: 

• Bevel and Emboss > Inner Bevel 

• Bevel and Emboss > Outer Bevel 

6. Using the Property inspector, add color to the button. Using the Text tool, add text to the button.  

 These should match the color and font design of your page. 
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7. Switch to the Selection tool. Hold down Shift. Click on both the button and the text box to select both. 

8. Select Modify > Align > Center Vertical to align the text with the vertical center of the button. 

9. Select Modify > Align > Center Horizontal to align the text with the horizontal center of the button. 

 Later you will duplicate this first button to create the other buttons. If the text is centered, button labels with 
varying numbers of characters will all be well aligned. 

10. Click the Over tab at the top of the Button Editor (Figure 2). 

 

Over tab 

Figure 2 Over tab in Button Editor 

11. Click Copy Up Graphic to copy the Up graphic to the Over button state (Figure 3). 

 This saves you time and helps keep the look of the button consistent. 

 

Copy Up Graphic button 

Figure 3 Copy Up Graphic button 

12. Decide how you want the button to look when the pointer rolls over the button. Then change the copied graphic 
by modifying the color or effects of the text or the shape of the button. 

13. Click the Down tab. 
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14. Click Copy Over Graphic to copy the Over graphic to this button state. 

15. Decide how you want the button to look when visitors click the button. Add effects such as darkening the color. 
You can add a drop shadow to the shape by clicking Add Filters in the Property inspector, and then selecting 
Shadow and Glow > Drop Shadow. 

16. For this project, skip the Over While Down state. 

17. Click the Active Area tab. 

 The active area of the button is shown by green shading and red lines. This shading indicates the area visitors 
can click to activate the button. 

18. To change the size of the active area, drag the red guides (Windows) or green shading (Macintosh) to extend or 
decrease the green shaded active area. 

19. When you are satisfied with the states of your button in the Button Editor, click Done. 

 Your button appears on the Fireworks canvas. 

20. Click the button to select it. In the Link text box in the Property inspector, enter the name of a web page to link 
it to this button (Figure 4). 

 
Figure 4 Web page in Link text box 

21. In the Alt text box, enter an alternative text label (Alt tag) for the button. 

 Alternative text is displayed in place of the image when visitors elect not to display images in their browsers. 
Such text can also be voiced by screen readers for visitors who use them. 

22. Select Modify > Canvas > Fit Canvas to fit the canvas to the size of your button. 
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Copy Buttons and Make the Navigation Bar 

1. Change the size of the canvas to accommodate all the 
buttons on your navigation bar. Select 
Modify > Canvas > Canvas Size and edit the value for 
height or width in the Canvas Size dialog box. 

 If you have four buttons, for example, multiply the 
height or width of the first button by four (depending on 
whether your navigation bar is vertical or horizontal). 

2. Select the first button. Move it to the top of the canvas. 
Select Edit > Clone. 

 A new instance of the button appears on top of the 
original button. 

3. Drag the new button instance below the original button. 
You can also use the arrow keys to move the button. 

4. Repeat steps 2 and 3 as many times as necessary to 
create the rest of your navigation bar (Figure 5). 

5. Click the second button and use the Property inspector 
to edit it. In the text box labeled “Text,” change the text 
to the name of the second button. Edit the information in 
the Link text box and the Alt text box as appropriate for 
this button. 

6. Repeat step 5 for the remaining buttons (Figure 6). 

7. Fit the canvas to your navigation bar: Select 
Modify > Canvas > Fit Canvas. 

8. Save the file. 

 
Figure 5 Cloned buttons 

 

 
Figure 6 Buttons with edited text labels 

Export a Navigation Bar for Use in Dreamweaver 

Fireworks enables you to save interactive graphics (a button, for instance) as HTML so you can import working 
buttons into a Dreamweaver document. 

1. To export your navigation bar, choose File > Export. 

 The Export dialog box opens (Figure 7). 

2. Navigate to the folder in your local root folder where you 
want to save the navigation bar. 

3. Give the navigation bar file a short descriptive name. 

4. Make sure the HTML and Images option is selected in 
the Save as type (Windows) or Save As (Macintosh) box. 

5. Make sure the Include areas without slices option is 
selected. 

6. Select the Put images in subfolder option. 

7. Click Export. 

8. Close Fireworks. 

 
Figure 7 Export dialog box 
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Insert the Navigation Bar into a Dreamweaver Document 

1. Start Dreamweaver. 

2. Open the page in which you want to insert the navigation 
bar. 

3. Position the insertion point where you want the navigation 
bar to appear. 

4. In the Common category on the Insert bar, click the 
Images pop-up menu and select Fireworks HTML. 

 The Insert Fireworks HTML dialog box opens (Figure 8). 

5. In the Insert Fireworks HTML dialog box, click the 
Browse button, and then locate and select your navigation 
bar HTML file. Click Open. 

6. In the Insert Fireworks HTML dialog box, click OK. 

 The navigation bar appears on the page. 

7. To edit a button, select the button and then use the 
Property inspector to change settings such as the link or 
alternative text. 

8. Check that the link address and the alternative text label 
are correct for each button. 

9. Select File > Preview in Browser and choose a browser 
from the submenu to test the buttons and their links in a 
browser (Figure 9). 

10. Save the Dreamweaver document. 

 
Figure 8 Fireworks HTML dialog box 

 

 
Figure 9 Page previewed in browser 
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How to Check Links 

A key technical testing task is to check all the links. Macromedia Dreamweaver 8 enables you to do this 
automatically. 

1. Start Dreamweaver. 

2. Make sure your site is open. 

3. On the menu bar, select Site > Check Links Sitewide. 

 The Link Checker tab displays all the broken links in the site (Figure 1). 

 
Figure 1 Link Checker tab 

 Note: Even though links are listed as broken, check them in the browser to confirm. 

4. Fix the broken links and check the links again. 
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How to Publish Web Files 

After you finish editing your documents, you need to publish them to your web server so the documents can be 
viewed. 

Connecting to a Remote Site 

Many websites let you publish files through FTP (File Transfer Protocol). You connect to a remote site by using the 
Site Definition dialog box in Macromedia Dreamweaver 8. 

1. Select Site > Manage Sites from the menu bar. 

 The Manage Sites dialog box opens (Figure 1). 

2. Select the name of the site you want to connect remotely, 
and click Edit. 

 The Site Definition dialog box opens. 

3. Click the Advanced tab and select the Remote Info 
category in the Site Definition dialog box (Figure 2). 

4. Select FTP in the Access menu. 

5. Enter the FTP access information as directed by your 
teacher. 

6. Click Test to test the connection. 

 Dreamweaver confirms the connection. 

7. Click OK. 
 

 
Figure 1 Manage Sites dialog box 

 

 
Figure 2 Site Definition dialog box  
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Uploading and Downloading Files 

Once you establish an FTP connection, you can publish files directly from the Files panel. 

Uploading the entire site for the first time 

1. Make sure the Files panel is open (Figure 3). 

 In Windows, it is docked at the right side of the screen. 
If the Files panel is not open, select Window > Files. 

2. Click the Expand/Collapse button in the Files panel 
toolbar (Figure 3). 

 The Files panel expands (Figure 4). 

3. Make sure the Connects to Remote Host button is 
active. (Figure 4). 

 Dreamweaver connects to the web server. 

4. Select the root folder for your site in the Local (right) 
pane. 

5. Click the Put Files button (the upward-pointing arrow).

 Dreamweaver uploads the site’s files and opens the 
Background File Activity dialog box (Figure 5). 

 Note: To upload one or more folders or files without 
uploading the entire site, select them and click the Put 
Files button. 

Uploading a revised version of an existing file 

1. Select the file you have revised. 

2. Click the Put Files button. 

 Dreamweaver uploads the revised file. 

 

 

 
 

Figure 3 Files panel 

 

 
 

Figure 4 Expanded Files panel 

 

 
Figure 5 Background File Activity dialog box 

Expand/Collapse button 

Put button Connects to Remote Host 
button
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Downloading files to work on them 

Once your website has been published, you will often want 
to download a file so you can revise it. You do so through 
the Remote Site pane, on the left side of the expanded Files 
panel. 

1. Click the Refresh button (Figure 6) to make sure the 
files in the Remote Site pane are up-to-date. 

2. Select a file to download. 

3. Click the Get Files button (Figure 6). 

 If the file has any dependent files, the Dependent Files 
dialog box opens (Figure 7). Dependent files are files, 
such as images or Flash movies, incorporated into a web 
page. In most cases, you need to download these in 
order for a web page to appear correctly. 

4. Click Yes. 

 Dreamweaver copies the file and its dependent files to 
your local folder. The file appears in the left pane of the 
expanded Files panel.  

 

 
 

Figure 6 Get button 

 

 
Figure 7 Dependent Files dialog box 

Refresh button Get button 
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Managing Files and Links by Using the Files Panel 

You can organize and manage your site files and folders by using the Files panel. Use the Files panel to open, add, 
rename, or delete files and folders. Use the Files panel to modify links. The site map provides a graphic 
representation of your site files and links. 

Opening Files 

1. Make sure the Files panel is visible (Figure 1). 

 In Windows, it is docked at the right side of the screen. 
If the Files panel is not open, select Window > Files. 

2. Select a file in the Files panel. 

3. Press Enter (Windows) or Return (Macintosh) to open 
the file in Dreamweaver. 

 Note: If you have Check in/Check out enabled, 
Dreamweaver will check the file out before it opens the 
file. If another visitor has checked out the file, you will 
be unable to open it. 

 
 

 
Figure 1 Files panel 
 

Renaming Files 

When you rename a file in the Files panel, Dreamweaver can automatically change links that point to this file. For 
this reason, it is always preferable to rename site files by using the Files panel instead of renaming them on your 
hard disk. 

1. Do one of the following to select the name of a file or 
folder in the Files panel: 

• Click the name, pause, and then click again. 

• Right-click (Windows) or Control-click 
(Macintosh) the file or folder icon, and then select 
Edit > Rename. 

2. Type the new name. 

3. Press Enter (Windows) or Return (Macintosh). 

 If any site links point to the file or folder, the Update 
Files dialog box opens (Figure 2). 

4. Click Update to change links that point to the renamed 
file or to a file in the renamed folder. 

Figure 2 Update Files dialog box 
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Deleting Files 

When you delete a file or folder, Dreamweaver will warn you if links point to the file or folder. 

1. Click the file or folder in the Files panel you want to 
delete. 

2. Press Delete. 

 If any site links point to the file or folder, the Delete 
Files warning opens (Figure 3), giving you the 
opportunity to change the links before you delete the 
file. 

 To delete the file anyway, click Yes. To cancel your 
request to delete the file, click No. 

 
Figure 3 Delete files warning 

Changing Links to a File 

You can also change links to a file through the Files panel. It is a good idea to change links before you delete a file 
to which other files are linked. 

1. Select a file in the Files panel. 

2. Select Site > Change Link Sitewide. 

 The Change Link Sitewide dialog box opens (Figure 4).

3. In the Into Links To field, enter the name of the file to 
which new links should point. 

4. Click OK. 

 The Update Files dialog box opens (Figure 5). 

5. Click Update. 
 

Figure 4 Change Links Sitewide dialog box 

 

Figure 5 Update Files dialog box 
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Creating a New Folder 

Use folders to keep your site well organized. For example, most websites use a folder named images to store all the 
images for the site. 

1. Right-click (Windows) or Control-click (Macintosh) the 
site root folder. 

 A context menu appears. 

2. Select New Folder. 

 The new folder appears as a subfolder of the root folder. 
The name of the folder should be highlighted 
(Figure 6). 

3. Type a name for the folder. 

4. Press Enter (Windows) or Return (Macintosh). 

 

 
Figure 6 Naming a new folder 
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Using the Site Map 

You can view a local folder for a Dreamweaver site as a visual map of linked icons, called a site map. 

Setting a home page 

To view a site map, you first need to set a home page for your site. 

1. In the Files panel (Window > Files), select a site. 

2. Right-click (Windows) or Control-click (Macintosh) the 
file you want to be the home page, such as index.html 
(Figure 7). 

 A context menu appears. 

3. Select Set as Home Page in the context menu. 

Viewing the site map 

4. In the Files panel (Figure 7), select Map View in the 
Site View pop-up menu. 

 The Files panel switches from Local view to Map view 
(Figure 8).  

 
Figure 7 Files panel 

 

 
Figure 8 Map view 
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Expanding and Contracting the Files Panel 

You can expand the Files panel to view sites in more detail. The expanded Files panel lets you view site files in two 
views at once, such as files on both remote and local servers or files in both list and site map views. 

To expand the Files panel: 

• In the Files panel (Figure 9), click the 
Expand/Collapse button in the toolbar. 

 The Files panel expands (Figure 10). 

 Note: If you click the Expand/Collapse button to 
expand the panel while it is docked, the panel 
maximizes so you cannot work in the Document 
window. To return to the Document window, click the 
Expand/Collapse button again to collapse the panel. 

To collapse the Files panel: 

• Click the Expand/Collapse button on the Files panel 
toolbar. 

 

 

 
 

Figure 9 Files panel 

 

Figure 10 Expanded Files panel 

Expand/Collapse button 
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HTML Tags 

The following is a quick reference guide for common tags used in HTML pages. 

Main Setup Tags for an HTML Document 

 
<HTML> 

<HEAD> 

<TITLE> 

</TITLE> 

</HEAD> 

<BODY> 

</BODY> 

</HTML> 

 
<HTML> </HTML> encompasses all tags in an HTML document and defines it as an HTML document. 

<HEAD> </HEAD> encompasses the title tag and contains document titles and authoring information for the 
document. 

<TITLE> </TITLE> encompasses the title for the document. 

<BODY> </BODY> encompasses all the tags that make up the document. 

<BODY BGCOLOR = “name of color”> </BODY> encompasses all the tags that make up the document and gives 
the document a background color. 

<BODY BACKGROUND = “title of image”> </BODY> encompasses all the tags that make up the document and 
gives the document a background image. 

Main Formatting Tags for the Document 

<H1> </H1> is a heading tag that creates the largest size text. The heading tag number can range from 1 to 6. 
Increasing the number makes the text smaller. 

<P> </P> creates paragraphs. 

<BR> </BR> creates a line break. 

<B> </B> bolds text. 

<STRONG> </STRONG> bolds text. 

<I> </I> italicizes text. 

<U> </U> underlines text 

<CENTER> </CENTER> centers text. 

<FONT COLOR = “name of color”> </FONT> changes the font color. 

Links 

<A HREF> </A> inserts a link. 
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Tables 

<TABLE> </TABLE> creates a table. This pair of tags encompasses all the row and cell tags in the table. 

<TR> </TR> creates the rows of a table. This pair of tags encompasses all the cell tags in the table. 

<TD> </TD> creates a cell in a table. 

Ordered Lists 

<OL> </OL> creates an ordered list. This pair of tags encompasses all the list tags for each item in the list. 

<LI> </LI> encompasses the list items. 

Unordered Lists 

<UL> </UL> creates an unordered list. This pair of tags encompasses all the list tags for each item in the list. 

<LI> </LI> encompasses the list items. 
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